Solución para Heartbleed
Fecha Friday, 11 April a las 00:27:23
Tema Tecnologias de Información


La noticia de un error en la librería criptográfica OpenSSL conocido como Hearthbleed ha corrido como reguero de pólvora por internet, y no es para menos, ya que una lista publicada por Mashable revela que son muchos los sitios que podrían verse afectados por este bug.

*Un bug es un error en un software o sistema que provoca resultados indeseados

En el caso de Hearthbleed, este error o bug, permite a un atacante obtener 64K de memoria que pueden contener credenciales de acceso a un servidor, cookies de sesión, claves privadas, conexiones a servidores u otros datos importantes.

Esta vulnerabilidad descubierta por ingenieros de Google y Codenomicon, una empresa finlandesa de ciberseguridad hizo que aquellos que trabajan de manera libre y colaborativa en crear la librería que muchas empresas usan para cifrar los datos fuera corregida lo antes posible y muchos servidores y sitios se encargaran de implementar un parche.

Cabe mencionar que hasta el momento, no se sabe si algún hacker, grupo de ciberdelincuentes o espias de gobiernos descubrieron este hueco de seguridad o si lo hicieron qué sitios fueron atacados y que datos se han filtrado.

Qué es OpenSSL

Es un proyecto de software libre cuyas librerías son usadas para codificar información sensible cuando se inicia sesión en sitios como Gmail, Facebook, Twitter, Bancos, Dependencias de Gobierno y más, y que hace que esta información viaje de ida y vuelta entre computadoras y servidores encriptada.

Como mencionamos, este software es creada de manera libre por ingenieros de todo el mundo de manera colaborativa, es decir, todos los involucrados aportan su granito de arena para crearlo y mejorarlo sin cobrar un centavo.

Sin embargo, hace un par de años, un desarrollador llamado Robin Seggelman que irónicamente trabajaba en ese tiempo en corregir errores y agregar nuevas características olvidó validar una variable y cuando su parte del código se unió al que se publica y usan muchos servidores, se creo el problema.

Quiénes se vieron afectados

De acuerdo a una encuesta reciente de Netcraft, aproximadamente el 66% de los servidores a nivel mundial usa OpenSSL, por lo que muchos servicios y empresas pudieron y pueden ver comprometida mucha información de sus usuarios.

Como usuario qué debo hacer

A pesar de que muchos servidores ya han arreglado el problema, existe aunque mínima, la posibilidad de que tus datos hayan caído en manos ajenas (aunque insistimos, es poco probable). así que te recomendamos que cambies tu contraseña cuanto antes.

Recuerda que para crear una password seguro debes usar mayúsculas, minúsculas, signos y números, y debe ser igual y mayor a 8 caracteres.

Ah, y muy importante, usa una contraseña para cada servicio de manera que si una se ve comprometida los demás no.

En caso de tener un servidor con OpenSSL, su versión debería ser la 1.0.1g o superior ya que el equipo tras OpenSSL ya ha puesto solución a heartbleed estas versiones. En caso de no poder cambiar la versión, siempre se puede recompilar OpenSSL con la opción -DOPEMSSL_NO_HEARTBEATS, aunque en cualquier caso lo mejor es dirigirse a una solución especializada. Así que, como vemos, en esta ocasión lo único que queda es prevenir y esperar, aunque por diferentes fallos técnicos nos tememos que heartbleed va a ser un fallo que dejará su huella durante mucho tiempo en la red. ¿Creará esto un efecto pre y post-heartbleed? La parte buena de todo este asunto es que se ha puesto de manifiesto la importancia de ser más precavido con la seguridad en las redes, aunque haya sido por las malas.

Fuente: Agentes





Este artículo proviene de Software Libre
http://www.somoslibres.org

La dirección de esta noticia es:
http://www.somoslibres.org/modules.php?name=News&file=article&sid=6612