Superan incidente crítico del kernel linux, en custión de tiempo
Fecha Saturday, 15 August a las 12:24:56
Tema GNU/LINUX


Dos expertos en seguridad han descubierto un error en el núcleo de Linux con el que se podría realizar un cambio en el sistema de privilegios. El fallo existe desde las versiones de 2001 pero los desarrolladores ya han sacado un parche con rapidez que soluciona este error.

En el blog de Tinnes los responsables del "Google Security Team" Tavis Ormandy y Julien Tinnes han publicado la noticia de la vulnerabilidad con la que se podría cambiar os privilegios de los distintos usuarios de Linux. Según comentan "El problema reside en cómo Linux se encarga de operaciones no disponibles para algunos protocolos y otros que no comprueban la existencia de punteros a NULL antes de desreferenciar operaciones en la estructura de operaciones".

Para un atacante que aproveche esta vulnerabilidad sería posible cambiar los privilegios de los usuarios mediante un exploit, pero el equipo de desarrolladores de Linux ya han sacado un parche que corrige este problema e incluso el propio Linux Torvalds ha sido el encargado de subirlo en el Git de Linux.

La actualización la podréis descargar desde los propios repositorios "universal" de Linux.

Ni siquiera el ultra aclamado por su seguridad Linux se libra de tener fallos de programación, como es normal, aunque lo realmente importante es tener un buen grupo de desarrolladores detrás que puedan arreglar los errores con rapidez.

Publicado el Parche

Fuente: http://blog.cr0.org/







Este artículo proviene de Software Libre
http://www.somoslibres.org

La dirección de esta noticia es:
http://www.somoslibres.org/modules.php?name=News&file=article&sid=2845